I’m trying to use SMTP to send emails using IBM JCL (IEBGENER). This is the JCL I’m using.I’m getting INVALID COMMAND errors on the. The data termination in SMTP step is period “.”. So keep on repeating these and you can create multiple emails. //IEBGENER JOB ACCT,’DATA. I suspect that your SMTP service was upgraded and may have become more sensitive to errors in setting up messages — your example has a few.

Author: Vudozragore Mikasho
Country: Mozambique
Language: English (Spanish)
Genre: Spiritual
Published (Last): 4 February 2018
Pages: 298
PDF File Size: 18.8 Mb
ePub File Size: 7.19 Mb
ISBN: 362-3-20234-368-4
Downloads: 22276
Price: Free* [*Free Regsitration Required]
Uploader: Fedal

mainframegurukul.com

Has been the email server or client updated? QUIT Note that the blank lines in the above exampe are significant and that the last boundary delimiter has two trailing hypens. My bad, you’re right. So it’s hard to pick the pit. Could someone let me know if it is related smgp internal support issue or something has been deprecated with SMTP utility.

Post Your Answer Discard By clicking “Post Your Answer”, you acknowledge that you have read our updated terms of serviceprivacy policy and cookie policyand that your continued use of the website is subject to these policies. Post as a guest Name.

  DEVACHANIC PLANE PDF

Here is the JCL used: All one physical line, just as shown. Since I receive different results than you, perhaps it is a configuration issue.

Still trying, thanks for your time. Proper usage of the boundary delimiter in a multipart message generally requires that the boundary delimiter be followed by oebgener blank line.

Sign up using Email and Password. Sign up or log in Sign up using Google. Raja Reddy 8 18 Taking all this into consideration, a conforming message would look more like: When I execute what you have posted, I receive Email Required, but never shown.

Here is the JCL used:. The Content-type of your message is not multipart so I imagine that “support” for the boundary subparameter may have been dropped yielding unpredictable results. All of sudden body content of the email is blank and shows no data, Email is being sent but without body content in the email but subject line is apprpriate.

Edited the answer and removed my comment.

By using our site, you acknowledge that you have read and understand our Cookie SmgpPrivacy Policyand our Terms of Service. The boundary subparameter of the Content-type parameter relates to multipart messages it is the boundary delimiter between message parts. The rules for the boundary subparameter are defined in RFC under multipart messages.

  AMPLIFICATEUR OPTIQUE EDFA PDF

Email is sent with no body content via SMTP on Mainframe – Stack Overflow

Sign up using Facebook. Surprisingly, It has worked till couple of days ago.

I suspect that your SMTP service was upgraded and may have become more sensitive to errors in setting up messages — your example has a few By clicking “Post Your Answer”, you acknowledge that you have read our updated terms of serviceprivacy policy and cookie policyand that your continued use of the website is subject to these policies.

Stack Overflow works best with JavaScript enabled. Unfortunately, I do not have access to the configuration files. Note that the blank lines in the above exampe are significant and that the last boundary delimiter has two trailing hypens. Also, the last boundary delimiter, the one that terminates the last part of the message should have two hyphens appended to it.